Flash9 en gardant Firefox64, possible et stable

10 juin 2007

Aujourd’hui, jour d’élections, j’avais envie de me mettre de bonne humeur. Regarder sur internet une vidéo de notre Président n’ayant « pas bu que de l’eau » par exemple, sur YouTube. Hélas! Étant sous Ubuntu 64bit, point de plugin flash, il nous faut encore attendre le bon vouloir d’Adobe, qui n’a toujours pas sorti de flash9 en version Linux64.

J’utilisais jusque là une version svn de Gnash, mais celui-ci n’est visiblement pas suffisant pour voir de telles vidéos. Je n’avais pas envie d’installer un deuxième Firefox, en version 32bit, pour simplement une ou deux utilisations par semaine. Je me suis souvenu avoir essayé il y a quelques temps quelque chose du nom de nspluginwrapper. Le nom vous semble familier ? Normal, il fonctionne comme ndiswrapper : il utilise des plugins 32bit sur un logiciel, en l’occurrence Firefox, en version 64bit. Je me suis tourné vers mon ami Kilz, et là en moins de temps qu’il n’en faut pour l’écrire, tout a marché.

De manière très simple et efficace, nspluginwrapper étant maintenant très stable, Kilz a écrit un script qui installe tout ça proprement et tout seul. Dans le détail, il télécharge et installe les librairies 32bit ainsi que ndiswrapper. Il crée ensuite l’environnement temporaire dans /tmp, télécharge la dernière version disponible du plugin flash. Enfin il installe tout ça, place le plugin dans les répertoires de Firefox et configure nspluginwrapper. Il termine par faire le ménage, et voilà. Relancez Firefox: flash fonctionne.

Le script étant mis à jour, je conseille à ceux qui ont installé la première version 0.1 ou 0.1.1 de le relancer. Nspluginwrapper et éventuellement votre plugin flash seront mis à jour, et le ménage de l’ancienne installation sera fait.

Le script se trouve ici. Téléchargez-le, décompressez l’archive. Rendez-vous dans le répertoire obtenu et double-cliquez sur GetFlash, choisissez lancer dans un Terminal, et le script se lance automatiquement.

Encore une fois : merci Kilz (PS: yes, life is great in 64bit !😉 ).

3 Réponses to “Flash9 en gardant Firefox64, possible et stable”


  1. […] un site web. Je conseille vivement à ceux qui comme moi utilisent le script de Kilz pour avoir Flash en 64bit de mettre à jour leur version de flash. Pour ce faire il suffit de relancer le script qui […]


  2. […] un site web. Je conseille vivement à ceux qui comme moi utilisent le script de Kilz pour avoir Flash en 64bit de mettre à jour leur version de flash. Pour ce faire il suffit de relancer le script qui […]


  3. […] un site web. Je conseille vivement à ceux qui comme moi utilisent le script de Kilz pour avoir Flash en 64bit de mettre à jour leur version de flash. Pour ce faire il suffit de relancer le script qui […]


Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :